Jump to content


Cannot install

error issue install admin

3 replies to this topic

#1 Tim Baker

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 15 March 2012 - 01:31 AM

I am unable to install the latest version, 1.02, from scratch (having no previous installations). When I try to run the installer, I receive the error "The system administrator has set policies to prevent this installation." I found that rather odd since, as the administrator of my own PC, I haven't set any such policies. I've never had any other trouble running MSI executables, or installing anything.

I am running Windows 7 64-bit, and I believe I have the correct version of the installer for that OS (it is named ChronoWall_1_0_2_x64.msi).

Here is what I've done so far:

-Tried editing security permissions for the executable. They all look fine, every user on my system has full rights to it. I did have to click the "Unblock" option at the bottom of the properties page first, then click "Apply" - this happens every now and then (seemingly at random) with downloaded files, but has never presented any problem before.
-Tried running as administrator. There is no right-click option for this, and the box in the executable's properties page (compatibility tab) is disabled, so there is no way to check it and have it always run as admin.
-Tried starting the "Windows Installer" service, since the installer is an .msi. This did nothing to change the error.

I have noticed another dialog pops up very briefly before the error, but it goes away so quick I am unable to read it.

#2 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 15 March 2012 - 06:57 AM

Tim,

Please see if the following will work:
http://answers.micro...49-20c6a7befb51

If the steps on that link fail, you may have to resort to installing ChronoWall without using the .msi. I have uploaded an "MSI-less" version of ChronoWall here:
http://chronowall.co...1_0_2_NoMSI.zip

Download that zip file and extract it to any directory of your choice (ChronoWall does not have to reside in the Program Files directory). If you choose to place it in the Program Files directory, you may need to be running as an elevated administrator if UAC is enabled.

After extraction, navigate to [ChronoWall directory]\D3DX and run DXSETUP.exe. This will install the minimum DirectX files necessary for the fade effect.

You will also need to install the following files from Microsoft:
http://www.microsoft...ails.aspx?id=29
http://www.microsoft...ls.aspx?id=5582
http://www.microsoft...ls.aspx?id=5555
http://www.microsoft...ls.aspx?id=8328

Those are the Visual Studio C++ redistributables, both the 2008, 2008 SPI, 2010 and 2010 SPI x86 versions (Windows 7 x64 should already come with the x64 versions). For any of those redistributables that you do not have, install them in the order listed.

Then, navigate to [ChronoWall Directory], right-click on ChronoWall.exe and select 'copy'. Then open the start menu, hover over 'All Programs', right-click it and select open. Choose a location in this new folder where you want to place the shortcut to ChronoWall. Right-click anywhere in the folder (on an empty spot in the window) and select "Paste Shortcut". You can also place a shortcut in the Startup folder if you wish.

Hope this helps!

#3 Tim Baker

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 15 March 2012 - 10:29 PM

Thanks! The zipped version is now installed and working just fine.

#4 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 16 March 2012 - 05:29 PM

No problem. I'm going to add this as another possible download (with a proper readme file included).





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users