Jump to content


Couple Bugs


4 replies to this topic

#1 StealthMonkey

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 27 August 2011 - 01:24 PM

Joshua,

I found a couple bugs.

First, the Enable/Disable button seems to get out of sync with the label bellow it. Sometimes when I click on it, the label will invert state, sometimes it won't. You can get it into states where the UI doesn't make sense:
Posted Image

Second, I am not sure if it is related to the new version (0.97) or not, but ChonoWall doesn't change my wallpaper anymore. I had turned it off a couple days ago and set my computer to another background. Then today I upgraded ChonoWall, started it up, and hit 'Change Now'. The ChronoWall UI reflects the change, but my desktop does not. I am running Windows 7 x64 and I installed the x64 MSI.

#2 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 27 August 2011 - 01:36 PM

StealthMonkey,

This could be due to the new fading mechanism. See if the following allows it to work:

  • Try changing your wallpaper a few times with the fade left enabled.

  • Disable 'Fade wallpaper when changing' (uncheck in the Settings view and select 'Save'), then right click on any picture file (outside of ChronoWall) and select 'Set as background'. After doing that, go back into ChronoWall and re-enable 'Fade wallpaper when changing' and click 'Change Now' again. If this method works, this could mean that you had a previous slideshow running in Windows 7 before launching ChronoWall - preventing the shell hook from working.

  • Try disabling 'Fade wallpaper when changing' and then change your wallpaper again. If it still doesn't work, leave the fade disabled and then try logging out/back in whenever you have the time to do so. This will leave the fade disabled but your wallpaper will still change.

It is very possible that another shell extension you have loaded is conflicting with ChronoWall's.

As far as the UI being in the wrong state - this is due to the second label not being redrawn after ChronoWall is enabled/disabled. If you move your window off-screen (after it being in that weird state) and move it back, you will see the correct state shown. I will definitely address this, and thanks for pointing that out!

#3 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 27 August 2011 - 02:01 PM

Okay,

I can confirm that if you have a Windows 7 slideshow running, the fade mechanism will not work. This is because Windows 7 changes the underlying hiearchy of windows that show up when using Windows 7's built-in transition support.

To address this, you can perform the following tasks:

  • Set a single wallpaper as your desktop in Windows 7's native 'Personalize' window
  • Log off and log back in
  • Launch ChronoWall and enable 'fade wallpaper when changing' if it is not already enabled.

You should now get a fading desktop from ChronoWall.


If you want to simply change your wallpaper (with no fade) without having to log in/out, you can perform the following tasks:

  • Disable 'Fade wallpaper when changing' in ChronoWall
  • Go to start->run... and type in 'taskkill /f /im:DesktopTransitionServer64.exe' if you are on 32-bit, replace DesktopTransitionServer64.exe with DesktopTransitionServer.exe.

You can now set your wallpaper in ChronoWall. It won't fade but at least it can be set.


Sorry for the inconvenience.. as I was unaware of this until now! This (along with the out-of-sync GUI bug) will be addressed in the next version (0.98).

#4 StealthMonkey

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 27 August 2011 - 06:27 PM

I read what you said and played around with it a little.

I can confirm that the enable/disable label is simply a painting issue.

It seems like you have it figured out, but I can say that the wallpaper changing issue seems to happen only if I try to enable ChronoWall and both (1) the current wallpaper is a slideshow (2) the fade effect is enabled. If I temporarily change either of those, I am able to get back into a good state. Logging in and out wasn't required.

#5 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 28 August 2011 - 10:45 AM

I am glad you were able to get it working! Apparently, when a slideshow is enabled, the normal 'ListView' control (which is really what the desktop in Windows is) gets changed around a bit. There are a couple of ways I can tackle this - either use the native Windows 7 fading if a slideshow has already been enabled or try to override the new window that is created. I really want to do the latter because with this new shell hook, I can eventually do some other interesting things (such as supporting viewing a video as your desktop, perhaps in a future version). Hopefully I will have a fix available soon after I return this Saturday.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users