Jump to content


Wallpaper Change Interval Issue


5 replies to this topic

#1 StealthMonkey

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 26 July 2011 - 11:48 PM

I've run into what looks like a bug. I added a bunch of wallpapers to the "Always" group (my other groups are empty) and set the interval of the Always group to 2 hours. However, it was changing the wallpaper way more often than that. Then I noticed that on the main page it said, "Your wallpaper is currently changing every 3 minutes". I looked and 3 minutes is the setting for all of the other empty groups. I right-clicked and disabled all of the other groups and the text on the main page corrected to "...every 2 hours". So, somehow the interval of empty groups is taking precedent.

This is where it gets really weird... If I right-click on some of the disabled groups and select Enable, it stays at 2 hours. Doing the same thing on some of the other groups changes it back to 3 minutes.

If you need additional information to track this down, let me know.

--Matt

#2 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 27 July 2011 - 12:08 AM

Thank you for pointing that out. I never thought to ignore the change frequency when dealing with empty groups. It definitely makes more sense to do so.

When you re-enabled the empty group, the code should have reset the frequency to three minutes. I will have to look over the code to see what is going on. I'll definitely have this fixed in the next version (0.94).

As far as the change frequency goes, I am actually deciding whether to migrate to a "global" change frequency that is independent of each group. There are benefits and drawbacks of each implementation.

#3 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 31 July 2011 - 11:27 PM

Due to the weekly releases that I am trying to maintain, I was unable to address this issue by 0.94. Rest assured I haven't forgotten about it!

#4 StealthMonkey

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 01 August 2011 - 12:13 AM

No worries. B)

#5 Tim Baker

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 15 March 2012 - 10:48 PM

Not sure if this issue has been addressed or not, but I've encountered a similar problem. Mine is stuck on the "every 3 minutes" interval and won't change no matter what kind of settings I use, which groups are active or inactive, or whatever. I even deleted all the groups but one (since enabling only one did not work) and when I change the interval for that group, not only does it not change (the home screen still says "every 3 minutes") but when I go back in to edit the frequency, it has changed and the "never" (no change) is selected.

EDIT: Must have been a bug with selecting "24 hours" - I got it to change by using "18 hours" instead. Is it supposed to support any value there? If so, I'd say it's a bug.

#6 Joshua Pilkington

    Administrator

  • Administrators
  • 91 posts
  • LocationCharlotte, NC

Posted 16 March 2012 - 05:23 PM

ChronoWall currently only allows a maximum of 24 hours (1 day) for a change frequency. It enforces this limit by modding any time entered with 24 hours. Since you actually entered 24 hours, it ended up being zero. If the number 0 is enterered (for any of the three possible values: seconds, minutes, hours), ChronoWall will reset it to "never". In fact, you will get the same behavior if you enter 1440 minutes or even 86400 seconds. Interestingly, if you enter 1441 minutes, the change frequency will actually be 1 minute. You would also get 1 second had you entered 86401 seconds.

Fortunately, there is still a way to change the wallpaper once per day. Simply set the change frequency to never. Every day at 12:00 AM local time, ChronoWall will reload the schedule - this forces a wallpaper change.

I'll update the online help manual to explain the limitations of the change frequency.

Thanks for pointing that out though - it's definitely something I should have mentioned in the online help.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users